Increasing Root the disk space for the VMware vCenter Server Appliance in vSphere 6.7

 

Disk VMDK) Default Size
(Tiny VCSA)
Mount Point Purpose
VMDK1 12GB / (10GB)
/boot (132MB)
SWAP (1GB)
Boot directory where the kernel images and boot load configurations are stored

Edit Disk

1526625184043

  1. Log in to the PSC using SSH and root credentials.
  2. Run this command to enable the Bash shell:
    shell.set --enabled true
  3. Type shell and press Enter.
  4. Use this command to verify which disk is experiencing disk space issues:
    df -h
  5. After the virtual disk is increased, return to the SSH session and run this command to automatically expand any logical volumes for which the physical volumes are increased:
     /usr/lib/applmgmt/support/scripts/resize-root.py
  6. Run this command to confirm that the virtual disk has been successfully grown:
    df -h

    1526625657184.jpg

Upgrade Snipe-IT V5>6.0.7

UBUNTU 20.0


snipeit:backup
OR Backup On Website 

Then rename the current Snipe-IT directory and clone the latest version via git:

cd /var/www
sudo mv snipe-it snipe-it-backup
sudo git clone https://github.com/snipe/snipe-it

Now fix permissions, enter the snipe-it dir and install dependencies with composer:

sudo chown -R www-data:www-data snipe-it
cd snipe-it
sudo composer install --no-dev --prefer-source
That will likely take a little while. When it's done, copy in the required old files:

sudo cp -R ../snipe-it-backup/public/uploads/* public/uploads
sudo cp -R ../snipe-it-backup/storage/private_uploads/* storage/private_uploads
sudo cp -R ../snipe-it-backup/storage/app/backups/* storage/app/backups
sudo cp -R ../snipe-it-backup/.env ./
sudo cp -R ../snipe-it-backup/storage/oauth-private.key storage/oauth-private.key
sudo cp -R ../snipe-it-backup/storage/oauth-public.key storage/oauth-public.key

sudo cp -R ../snipeit.save/public/uploads/* public/uploads
sudo cp -R ../snipeit.save/storage/private_uploads/* storage/private_uploads
sudo cp -R ../snipeit.save/storage/app/backups/* storage/app/backups
sudo cp -R ../snipeit.save/.env ./
sudo cp -R ../snipeit.save/storage/oauth-private.key storage/oauth-private.key
sudo cp -R ../snipeit.save/storage/oauth-public.key storage/oauth-public.key


Then finally, you can run the update itself (migrate DB, clear cache, etc). Unfortunately this command is a little convoluted, but perhaps we'll write a helper script for that too in the future?:

sudo runuser - www-data -s /bin/bash -c "cd /var/www/snipe-it && php upgrade.php"

Updated: SAS HBA crossflashing or flashing to IT mode, Dell Perc H200 and H310

Dell Raid To PC WOW

techmattr

Default firmware for this guide is:
2118it.bin
Version 20.00.07.00
Release date: 11-FEB-16

WARNING: If you have an Integrated, Mini or Mini Mono Perc H310 do NOT try to crossflash with these steps.

So this guide will be the update to my first guide… without double checking everything I’m pretty sure it’s almost identical except for the link to the ZIP file. So I’m not sure why I retyped all of this instead of just updating the ZIP file in the old guide. Anyway…. the difference between the old and new ZIP file is the sas2flsh and sas2flash versions. The default sas2flsh.exe and sas2flash.efi in this new ZIP file are p5 which allows you to pretty much overwrite/downgrade any firmware. This will help mainly those who were getting stuck on the H200 cards. I’ve also included driver, firmware and sas2flash folders that contain a wide array of sometimes hard to find…

View original post 1,741 more words

How to update ESXi 6.5 to ESXi 6.7 via offline bundle

How to update ESXi 6.5 to ESXi 6.7 via offline bundle

How to update ESXi 6.5 to ESXi 6.7 via offline bundle

in this post, we will look at how to upgrade ESXi 6.5 to ESXi 6.7 via Offline Bundle. I have old Fujitsu node (RX300 S7) in my demolab, with ESXi 6.5.0 build-6765664 (Fujitsu customized image). We need customized offline bundle

the zip file contains image which can be used to perform upgrade.

Upload the Offline Bundle file to one of the shared datastores that the ESXi host have access.

Upgrade process:

  • Make sure that you have migrated all the VMs from upgraded host
  • Put the host in maintenance mode.
  • Verify Offline Bundle – esxcli software sources profile list -d 
  • Start upgrade process esxcli software profile update -p x -d x
  • Reboot
  • Verify version

in my case: 

[root@esx1:~] vmware -vl
VMware ESXi 6.5.0 build-6765664

VMware ESXi 6.5.0 Update 1

[root@esx1:~] esxcli software sources profile list -d /vmfs/volumes/IFN_10TB/install/VMware-ESXi-6.7.0-8169922-Fujitsu-v450-1-offline_bundle.zip 

Name                                          Vendor   Acceptance Level

--------------------------------------------  -------  ----------------

Fujitsu-VMvisor-Installer-6.7-8169922-v450-1  Fujitsu  PartnerSupported
[root@esx1:~] esxcli software profile update -p Fujitsu-VMvisor-Installer-6.7-8169922-v450-1 -d /vmfs/volumes/IFN_10TB/install/VMware-ESXi-6.7.0-8169922-Fujitsu-v450-1-offline_bundle.zip 

Update Result

   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.

   Reboot Required: true

   VIBs Installed: ELX_bootbank_elx-esx-libelxima.so_12.0.1108.0-03, EMULEX_bootbank_emulex-esx-brcmfcoecli_12.0.1113.0-01, EMULEX_bootbank_emulex-esx-elxlpfccli_11.4.334.5-01, EMULEX_bootbank_emulex-esx-elxmgmt_11.4.337.0-01, EMULEX_bootbank_emulex-esx-elxnetcli_12.0.1115.0-03, EMU_bootbank_brcm-cim-provider_12.0.1113.0-01OEM.670.0.0.7535516, EMU_bootbank_brcmfcoe_12.0.1115.0-1OEM.670.0.0.7535516, EMU_bootbank_elxiscsi_12.0.1108.0-1OEM.670.0.0.7535516, EMU_bootbank_elxnet_12.0.1115.0-1OEM.670.0.0.7535516, EMU_bootbank_emulex-cim-provider_11.4.341.0-01OEM.670.0.0.7535516, EMU_bootbank_lpfc_11.4.341.0-1OEM.670.0.0.7535516, Fujitsu_bootbank_fujitsu-conf_6.7.0-450.1.0, Fujitsu_bootbank_pci-fujitsu-hti_8.20.04-1OEM.600.0.0.2494585, Fujitsu_bootbank_raid0_8.30.08-01, Fujitsu_bootbank_svscimprovider_8.30-08.60, LSI_bootbank_lsiprovider_500.04.V0.65-0003, VMW_bootbank_ata-libata-92_3.00.9.2-16vmw.670.0.0.8169922, VMW_bootbank_ata-pata-amd_0.3.10-3vmw.670.0.0.8169922, VMW_bootbank_ata-pata-atiixp_0.4.6-4vmw.670.0.0.8169922, VMW_bootbank_ata-pata-cmd64x_0.2.5-3vmw.670.0.0.8169922, VMW_bootbank_ata-pata-hpt3x2n_0.3.4-3vmw.670.0.0.8169922, VMW_bootbank_ata-pata-pdc2027x_1.0-3vmw.670.0.0.8169922, VMW_bootbank_ata-pata-serverworks_0.4.3-3vmw.670.0.0.8169922, VMW_bootbank_ata-pata-sil680_0.4.8-3vmw.670.0.0.8169922, VMW_bootbank_ata-pata-via_0.3.3-2vmw.670.0.0.8169922, VMW_bootbank_block-cciss_3.6.14-10vmw.670.0.0.8169922, VMW_bootbank_bnxtnet_20.6.101.7-11vmw.670.0.0.8169922, VMW_bootbank_char-random_1.0-3vmw.670.0.0.8169922, VMW_bootbank_ehci-ehci-hcd_1.0-4vmw.670.0.0.8169922, VMW_bootbank_hid-hid_1.0-3vmw.670.0.0.8169922, VMW_bootbank_i40en_1.3.1-18vmw.670.0.0.8169922, VMW_bootbank_iavmd_1.2.0.1011-2vmw.670.0.0.8169922, VMW_bootbank_igbn_0.1.0.0-15vmw.670.0.0.8169922, VMW_bootbank_ima-qla4xxx_2.02.18-1vmw.670.0.0.8169922, VMW_bootbank_ipmi-ipmi-devintf_39.1-4vmw.670.0.0.8169922, VMW_bootbank_ipmi-ipmi-msghandler_39.1-4vmw.670.0.0.8169922, VMW_bootbank_ipmi-ipmi-si-drv_39.1-4vmw.670.0.0.8169922, VMW_bootbank_iser_1.0.0.0-1vmw.670.0.0.8169922, VMW_bootbank_ixgben_1.4.1-11vmw.670.0.0.8169922, VMW_bootbank_lpnic_11.4.59.0-1vmw.670.0.0.8169922, VMW_bootbank_lsi-mr3_7.702.13.00-4vmw.670.0.0.8169922, VMW_bootbank_lsi-msgpt2_20.00.04.00-4vmw.670.0.0.8169922, VMW_bootbank_lsi-msgpt35_03.00.01.00-10vmw.670.0.0.8169922, VMW_bootbank_lsi-msgpt3_16.00.01.00-1vmw.670.0.0.8169922, VMW_bootbank_misc-cnic-register_1.78.75.v60.7-1vmw.670.0.0.8169922, VMW_bootbank_misc-drivers_6.7.0-0.0.8169922, VMW_bootbank_mtip32xx-native_3.9.6-1vmw.670.0.0.8169922, VMW_bootbank_ne1000_0.8.3-4vmw.670.0.0.8169922, VMW_bootbank_nenic_1.0.11.0-1vmw.670.0.0.8169922, VMW_bootbank_net-bnx2_2.2.4f.v60.10-2vmw.670.0.0.8169922, VMW_bootbank_net-bnx2x_1.78.80.v60.12-2vmw.670.0.0.8169922, VMW_bootbank_net-cdc-ether_1.0-3vmw.670.0.0.8169922, VMW_bootbank_net-cnic_1.78.76.v60.13-2vmw.670.0.0.8169922, VMW_bootbank_net-e1000_8.0.3.1-5vmw.670.0.0.8169922, VMW_bootbank_net-e1000e_3.2.2.1-2vmw.670.0.0.8169922, VMW_bootbank_net-enic_2.1.2.38-2vmw.670.0.0.8169922, VMW_bootbank_net-fcoe_1.0.29.9.3-7vmw.670.0.0.8169922, VMW_bootbank_net-forcedeth_0.61-2vmw.670.0.0.8169922, VMW_bootbank_net-igb_5.0.5.1.1-5vmw.670.0.0.8169922, VMW_bootbank_net-ixgbe_3.7.13.7.14iov-20vmw.670.0.0.8169922, VMW_bootbank_net-libfcoe-92_1.0.24.9.4-8vmw.670.0.0.8169922, VMW_bootbank_net-mlx4-core_1.9.7.0-1vmw.670.0.0.8169922, VMW_bootbank_net-mlx4-en_1.9.7.0-1vmw.670.0.0.8169922, VMW_bootbank_net-nx-nic_5.0.621-5vmw.670.0.0.8169922, VMW_bootbank_net-tg3_3.131d.v60.4-2vmw.670.0.0.8169922, VMW_bootbank_net-usbnet_1.0-3vmw.670.0.0.8169922, VMW_bootbank_net-vmxnet3_1.1.3.0-3vmw.670.0.0.8169922, VMW_bootbank_nhpsa_2.0.22-1vmw.670.0.0.8169922, VMW_bootbank_nmlx4-core_3.17.9.12-1vmw.670.0.0.8169922, VMW_bootbank_nmlx4-en_3.17.9.12-1vmw.670.0.0.8169922, VMW_bootbank_nmlx4-rdma_3.17.9.12-1vmw.670.0.0.8169922, VMW_bootbank_nmlx5-core_4.17.9.12-1vmw.670.0.0.8169922, VMW_bootbank_nmlx5-rdma_4.17.9.12-1vmw.670.0.0.8169922, VMW_bootbank_ntg3_4.1.3.0-1vmw.670.0.0.8169922, VMW_bootbank_nvme_1.2.1.34-1vmw.670.0.0.8169922, VMW_bootbank_nvmxnet3-ens_2.0.0.21-1vmw.670.0.0.8169922, VMW_bootbank_nvmxnet3_2.0.0.27-1vmw.670.0.0.8169922, VMW_bootbank_ohci-usb-ohci_1.0-3vmw.670.0.0.8169922, VMW_bootbank_pvscsi_0.1-2vmw.670.0.0.8169922, VMW_bootbank_qcnic_1.0.2.0.4-1vmw.670.0.0.8169922, VMW_bootbank_qedentv_2.0.6.4-8vmw.670.0.0.8169922, VMW_bootbank_qfle3_1.0.50.11-9vmw.670.0.0.8169922, VMW_bootbank_qfle3f_1.0.25.0.2-14vmw.670.0.0.8169922, VMW_bootbank_qfle3i_1.0.2.3.9-3vmw.670.0.0.8169922, VMW_bootbank_qflge_1.1.0.11-1vmw.670.0.0.8169922, VMW_bootbank_sata-ahci_3.0-26vmw.670.0.0.8169922, VMW_bootbank_sata-ata-piix_2.12-10vmw.670.0.0.8169922, VMW_bootbank_sata-sata-nv_3.5-4vmw.670.0.0.8169922, VMW_bootbank_sata-sata-promise_2.12-3vmw.670.0.0.8169922, VMW_bootbank_sata-sata-sil24_1.1-1vmw.670.0.0.8169922, VMW_bootbank_sata-sata-sil_2.3-4vmw.670.0.0.8169922, VMW_bootbank_sata-sata-svw_2.3-3vmw.670.0.0.8169922, VMW_bootbank_scsi-aacraid_1.1.5.1-9vmw.670.0.0.8169922, VMW_bootbank_scsi-adp94xx_1.0.8.12-6vmw.670.0.0.8169922, VMW_bootbank_scsi-aic79xx_3.1-6vmw.670.0.0.8169922, VMW_bootbank_scsi-bnx2fc_1.78.78.v60.8-1vmw.670.0.0.8169922, VMW_bootbank_scsi-bnx2i_2.78.76.v60.8-1vmw.670.0.0.8169922, VMW_bootbank_scsi-fnic_1.5.0.45-3vmw.670.0.0.8169922, VMW_bootbank_scsi-hpsa_6.0.0.84-3vmw.670.0.0.8169922, VMW_bootbank_scsi-ips_7.12.05-4vmw.670.0.0.8169922, VMW_bootbank_scsi-iscsi-linux-92_1.0.0.2-3vmw.670.0.0.8169922, VMW_bootbank_scsi-libfc-92_1.0.40.9.3-5vmw.670.0.0.8169922, VMW_bootbank_scsi-megaraid-mbox_2.20.5.1-6vmw.670.0.0.8169922, VMW_bootbank_scsi-megaraid-sas_6.603.55.00-2vmw.670.0.0.8169922, VMW_bootbank_scsi-megaraid2_2.00.4-9vmw.670.0.0.8169922, VMW_bootbank_scsi-mpt2sas_19.00.00.00-2vmw.670.0.0.8169922, VMW_bootbank_scsi-mptsas_4.23.01.00-10vmw.670.0.0.8169922, VMW_bootbank_scsi-mptspi_4.23.01.00-10vmw.670.0.0.8169922, VMW_bootbank_scsi-qla4xxx_5.01.03.2-7vmw.670.0.0.8169922, VMW_bootbank_shim-iscsi-linux-9-2-1-0_6.7.0-0.0.8169922, VMW_bootbank_shim-iscsi-linux-9-2-2-0_6.7.0-0.0.8169922, VMW_bootbank_shim-libata-9-2-1-0_6.7.0-0.0.8169922, VMW_bootbank_shim-libata-9-2-2-0_6.7.0-0.0.8169922, VMW_bootbank_shim-libfc-9-2-1-0_6.7.0-0.0.8169922, VMW_bootbank_shim-libfc-9-2-2-0_6.7.0-0.0.8169922, VMW_bootbank_shim-libfcoe-9-2-1-0_6.7.0-0.0.8169922, VMW_bootbank_shim-libfcoe-9-2-2-0_6.7.0-0.0.8169922, VMW_bootbank_shim-vmklinux-9-2-1-0_6.7.0-0.0.8169922, VMW_bootbank_shim-vmklinux-9-2-2-0_6.7.0-0.0.8169922, VMW_bootbank_shim-vmklinux-9-2-3-0_6.7.0-0.0.8169922, VMW_bootbank_smartpqi_1.0.1.553-10vmw.670.0.0.8169922, VMW_bootbank_uhci-usb-uhci_1.0-3vmw.670.0.0.8169922, VMW_bootbank_usb-storage-usb-storage_1.0-3vmw.670.0.0.8169922, VMW_bootbank_usbcore-usb_1.0-3vmw.670.0.0.8169922, VMW_bootbank_vmkata_0.1-1vmw.670.0.0.8169922, VMW_bootbank_vmkfcoe_1.0.0.0-1vmw.670.0.0.8169922, VMW_bootbank_vmkplexer-vmkplexer_6.7.0-0.0.8169922, VMW_bootbank_vmkusb_0.1-1vmw.670.0.0.8169922, VMW_bootbank_vmw-ahci_1.2.0-6vmw.670.0.0.8169922, VMW_bootbank_xhci-xhci_1.0-3vmw.670.0.0.8169922, VMware_bootbank_cpu-microcode_6.7.0-0.0.8169922, VMware_bootbank_esx-base_6.7.0-0.0.8169922, VMware_bootbank_esx-dvfilter-generic-fastpath_6.7.0-0.0.8169922, VMware_bootbank_esx-ui_1.25.0-7872652, VMware_bootbank_esx-xserver_6.7.0-0.0.8169922, VMware_bootbank_lsu-hp-hpsa-plugin_2.0.0-13vmw.670.0.0.8169922, VMware_bootbank_lsu-lsi-lsi-mr3-plugin_1.0.0-12vmw.670.0.0.8169922, VMware_bootbank_lsu-lsi-lsi-msgpt3-plugin_1.0.0-8vmw.670.0.0.8169922, VMware_bootbank_lsu-lsi-megaraid-sas-plugin_1.0.0-9vmw.670.0.0.8169922, VMware_bootbank_lsu-lsi-mpt2sas-plugin_2.0.0-7vmw.670.0.0.8169922, VMware_bootbank_native-misc-drivers_6.7.0-0.0.8169922, VMware_bootbank_qlnativefc_3.0.1.0-5vmw.670.0.0.8169922, VMware_bootbank_rste_2.0.2.0088-7vmw.670.0.0.8169922, VMware_bootbank_vmware-esx-esxcli-nvme-plugin_1.2.0.32-0.0.8169922, VMware_bootbank_vsan_6.7.0-0.0.8169922, VMware_bootbank_vsanhealth_6.7.0-0.0.8169922, VMware_locker_tools-light_10.2.0.7253323-8169922

   VIBs Removed: ELX_bootbank_elx-esx-libelxima.so_11.1.216.0-03, EMU_bootbank_elxiscsi_11.1.216.0-1OEM.650.0.0.4240417, EMU_bootbank_emulex-cim-provider_11.1.196.3-01OEM.650.0.0.4240417, Fujitsu_bootbank_fujitsu-conf_6.5.0-400.1.0, Fujitsu_bootbank_svscimprovider_7.31-06.60, LSI_bootbank_lsiprovider_500.04.V0.61-0007, VMW_bootbank_ata-libata-92_3.00.9.2-16vmw.650.0.0.4564106, VMW_bootbank_ata-pata-amd_0.3.10-3vmw.650.0.0.4564106, VMW_bootbank_ata-pata-atiixp_0.4.6-4vmw.650.0.0.4564106, VMW_bootbank_ata-pata-cmd64x_0.2.5-3vmw.650.0.0.4564106, VMW_bootbank_ata-pata-hpt3x2n_0.3.4-3vmw.650.0.0.4564106, VMW_bootbank_ata-pata-pdc2027x_1.0-3vmw.650.0.0.4564106, VMW_bootbank_ata-pata-serverworks_0.4.3-3vmw.650.0.0.4564106, VMW_bootbank_ata-pata-sil680_0.4.8-3vmw.650.0.0.4564106, VMW_bootbank_ata-pata-via_0.3.3-2vmw.650.0.0.4564106, VMW_bootbank_block-cciss_3.6.14-10vmw.650.0.0.4564106, VMW_bootbank_char-random_1.0-3vmw.650.0.0.4564106, VMW_bootbank_ehci-ehci-hcd_1.0-4vmw.650.0.14.5146846, VMW_bootbank_elxnet_11.1.91.0-1vmw.650.0.0.4564106, VMW_bootbank_hid-hid_1.0-3vmw.650.0.0.4564106, VMW_bootbank_i40en_1.3.1-5vmw.650.1.26.5969303, VMW_bootbank_igbn_0.1.0.0-14vmw.650.1.26.5969303, VMW_bootbank_ima-qla4xxx_2.02.18-1vmw.650.0.0.4564106, VMW_bootbank_ipmi-ipmi-devintf_39.1-4vmw.650.0.0.4564106, VMW_bootbank_ipmi-ipmi-msghandler_39.1-4vmw.650.0.0.4564106, VMW_bootbank_ipmi-ipmi-si-drv_39.1-4vmw.650.0.0.4564106, VMW_bootbank_ixgben_1.4.1-2vmw.650.1.26.5969303, VMW_bootbank_lpfc_11.1.0.6-1vmw.650.0.0.4564106, VMW_bootbank_lsi-mr3_6.910.18.00-1vmw.650.0.0.4564106, VMW_bootbank_lsi-msgpt2_20.00.01.00-3vmw.650.0.0.4564106, VMW_bootbank_lsi-msgpt3_12.00.02.00-11vmw.650.0.0.4564106, VMW_bootbank_misc-cnic-register_1.78.75.v60.7-1vmw.650.0.0.4564106, VMW_bootbank_misc-drivers_6.5.0-1.26.5969303, VMW_bootbank_mtip32xx-native_3.9.5-1vmw.650.0.0.4564106, VMW_bootbank_ne1000_0.8.0-16vmw.650.1.26.5969303, VMW_bootbank_nenic_1.0.0.2-1vmw.650.0.0.4564106, VMW_bootbank_net-bnx2_2.2.4f.v60.10-2vmw.650.0.0.4564106, VMW_bootbank_net-bnx2x_1.78.80.v60.12-1vmw.650.0.0.4564106, VMW_bootbank_net-cdc-ether_1.0-3vmw.650.0.0.4564106, VMW_bootbank_net-cnic_1.78.76.v60.13-2vmw.650.0.0.4564106, VMW_bootbank_net-e1000_8.0.3.1-5vmw.650.0.0.4564106, VMW_bootbank_net-e1000e_3.2.2.1-2vmw.650.0.0.4564106, VMW_bootbank_net-enic_2.1.2.38-2vmw.650.0.0.4564106, VMW_bootbank_net-fcoe_1.0.29.9.3-7vmw.650.0.0.4564106, VMW_bootbank_net-forcedeth_0.61-2vmw.650.0.0.4564106, VMW_bootbank_net-igb_5.0.5.1.1-5vmw.650.0.0.4564106, VMW_bootbank_net-ixgbe_3.7.13.7.14iov-20vmw.650.0.0.4564106, VMW_bootbank_net-libfcoe-92_1.0.24.9.4-8vmw.650.0.0.4564106, VMW_bootbank_net-mlx4-core_1.9.7.0-1vmw.650.0.0.4564106, VMW_bootbank_net-mlx4-en_1.9.7.0-1vmw.650.0.0.4564106, VMW_bootbank_net-nx-nic_5.0.621-5vmw.650.0.0.4564106, VMW_bootbank_net-tg3_3.131d.v60.4-2vmw.650.0.0.4564106, VMW_bootbank_net-usbnet_1.0-3vmw.650.0.0.4564106, VMW_bootbank_net-vmxnet3_1.1.3.0-3vmw.650.0.0.4564106, VMW_bootbank_nhpsa_2.0.6-3vmw.650.0.0.4564106, VMW_bootbank_nmlx4-core_3.16.0.0-1vmw.650.0.0.4564106, VMW_bootbank_nmlx4-en_3.16.0.0-1vmw.650.0.0.4564106, VMW_bootbank_nmlx4-rdma_3.16.0.0-1vmw.650.0.0.4564106, VMW_bootbank_nmlx5-core_4.16.0.0-1vmw.650.0.0.4564106, VMW_bootbank_ntg3_4.1.2.0-1vmw.650.1.26.5969303, VMW_bootbank_nvme_1.2.0.32-4vmw.650.1.26.5969303, VMW_bootbank_nvmxnet3_2.0.0.22-1vmw.650.0.0.4564106, VMW_bootbank_ohci-usb-ohci_1.0-3vmw.650.0.0.4564106, VMW_bootbank_pvscsi_0.1-1vmw.650.1.26.5969303, VMW_bootbank_qedentv_2.0.3.29-1vmw.650.0.0.4564106, VMW_bootbank_qfle3_1.0.2.7-1vmw.650.0.0.4564106, VMW_bootbank_qflge_1.1.0.3-1vmw.650.0.0.4564106, VMW_bootbank_qlnativefc_2.1.50.0-1vmw.650.1.26.5969303, VMW_bootbank_sata-ahci_3.0-26vmw.650.1.26.5969303, VMW_bootbank_sata-ata-piix_2.12-10vmw.650.0.0.4564106, VMW_bootbank_sata-sata-nv_3.5-4vmw.650.0.0.4564106, VMW_bootbank_sata-sata-promise_2.12-3vmw.650.0.0.4564106, VMW_bootbank_sata-sata-sil24_1.1-1vmw.650.0.0.4564106, VMW_bootbank_sata-sata-sil_2.3-4vmw.650.0.0.4564106, VMW_bootbank_sata-sata-svw_2.3-3vmw.650.0.0.4564106, VMW_bootbank_scsi-aacraid_1.1.5.1-9vmw.650.0.0.4564106, VMW_bootbank_scsi-adp94xx_1.0.8.12-6vmw.650.0.0.4564106, VMW_bootbank_scsi-aic79xx_3.1-5vmw.650.0.0.4564106, VMW_bootbank_scsi-bnx2fc_1.78.78.v60.8-1vmw.650.0.0.4564106, VMW_bootbank_scsi-bnx2i_2.78.76.v60.8-1vmw.650.0.0.4564106, VMW_bootbank_scsi-fnic_1.5.0.45-3vmw.650.0.0.4564106, VMW_bootbank_scsi-hpsa_6.0.0.84-1vmw.650.0.0.4564106, VMW_bootbank_scsi-ips_7.12.05-4vmw.650.0.0.4564106, VMW_bootbank_scsi-iscsi-linux-92_1.0.0.2-3vmw.650.0.0.4564106, VMW_bootbank_scsi-libfc-92_1.0.40.9.3-5vmw.650.0.0.4564106, VMW_bootbank_scsi-megaraid-mbox_2.20.5.1-6vmw.650.0.0.4564106, VMW_bootbank_scsi-megaraid-sas_6.603.55.00-2vmw.650.0.0.4564106, VMW_bootbank_scsi-megaraid2_2.00.4-9vmw.650.0.0.4564106, VMW_bootbank_scsi-mpt2sas_19.00.00.00-1vmw.650.0.0.4564106, VMW_bootbank_scsi-mptsas_4.23.01.00-10vmw.650.0.0.4564106, VMW_bootbank_scsi-mptspi_4.23.01.00-10vmw.650.0.0.4564106, VMW_bootbank_scsi-qla4xxx_5.01.03.2-7vmw.650.0.0.4564106, VMW_bootbank_shim-iscsi-linux-9-2-1-0_6.5.0-0.0.4564106, VMW_bootbank_shim-iscsi-linux-9-2-2-0_6.5.0-0.0.4564106, VMW_bootbank_shim-libata-9-2-1-0_6.5.0-0.0.4564106, VMW_bootbank_shim-libata-9-2-2-0_6.5.0-0.0.4564106, VMW_bootbank_shim-libfc-9-2-1-0_6.5.0-0.0.4564106, VMW_bootbank_shim-libfc-9-2-2-0_6.5.0-0.0.4564106, VMW_bootbank_shim-libfcoe-9-2-1-0_6.5.0-0.0.4564106, VMW_bootbank_shim-libfcoe-9-2-2-0_6.5.0-0.0.4564106, VMW_bootbank_shim-vmklinux-9-2-1-0_6.5.0-0.0.4564106, VMW_bootbank_shim-vmklinux-9-2-2-0_6.5.0-0.0.4564106, VMW_bootbank_shim-vmklinux-9-2-3-0_6.5.0-0.0.4564106, VMW_bootbank_uhci-usb-uhci_1.0-3vmw.650.0.0.4564106, VMW_bootbank_usb-storage-usb-storage_1.0-3vmw.650.0.0.4564106, VMW_bootbank_usbcore-usb_1.0-3vmw.650.1.26.5969303, VMW_bootbank_vmkata_0.1-1vmw.650.1.26.5969303, VMW_bootbank_vmkplexer-vmkplexer_6.5.0-0.0.4564106, VMW_bootbank_vmkusb_0.1-1vmw.650.1.26.5969303, VMW_bootbank_vmw-ahci_1.0.0-39vmw.650.1.26.5969303, VMW_bootbank_xhci-xhci_1.0-3vmw.650.0.0.4564106, VMware_bootbank_cpu-microcode_6.5.0-0.0.4564106, VMware_bootbank_emulex-esx-elxnetcli_11.1.28.0-0.0.4564106, VMware_bootbank_esx-base_6.5.0-1.29.6765664, VMware_bootbank_esx-dvfilter-generic-fastpath_6.5.0-0.0.4564106, VMware_bootbank_esx-tboot_6.5.0-1.29.6765664, VMware_bootbank_esx-ui_1.21.0-5724747, VMware_bootbank_esx-xserver_6.5.0-0.23.5969300, VMware_bootbank_lsu-hp-hpsa-plugin_2.0.0-5vmw.650.1.26.5969303, VMware_bootbank_lsu-lsi-lsi-mr3-plugin_1.0.0-10vmw.650.1.26.5969303, VMware_bootbank_lsu-lsi-lsi-msgpt3-plugin_1.0.0-7vmw.650.1.26.5969303, VMware_bootbank_lsu-lsi-megaraid-sas-plugin_1.0.0-8vmw.650.1.26.5969303, VMware_bootbank_lsu-lsi-mpt2sas-plugin_2.0.0-6vmw.650.1.26.5969303, VMware_bootbank_native-misc-drivers_6.5.0-0.0.4564106, VMware_bootbank_rste_2.0.2.0088-4vmw.650.0.0.4564106, VMware_bootbank_vmware-esx-esxcli-nvme-plugin_1.2.0.10-1.26.5969303, VMware_bootbank_vsan_6.5.0-1.29.6765666, VMware_bootbank_vsanhealth_6.5.0-1.29.6765667, VMware_locker_tools-light_6.5.0-0.23.5969300

   VIBs Skipped:
[root@esx1:~]  reboot
[root@esx1:~] vmware -vl
VMware ESXi 6.7.0 build-8169922
VMware ESXi 6.7.0 GA

Easily update the BIOS and all firmware on your Dell PowerEdge server

ThatServerNerd.com

PowerEdgeLogo

Most might not think working with servers is fun. Most might not even list “I like long walks on the beach and Dell PowerEdge R730s with Intel X710 10Gb NICs” on their Tinder profile. But then again, you might be a homelabber who’s stoked to have scored one of those PowerEdge R710s on eBay for ridiculously cheap or you’re a SysAdmin whose proposal for one of those badass new four-socket PowerEdge servers got surprisingly approved. If you’re closer to the latter, then you agree that servers can actually be pretty fun.

You’ll also probably agree that updating all of the firmware/drivers/etc. on a server can be very tedious and boring. Even more so if it’s been neglected and everything is severely in need of an update. If the process isn’t automated in some way, it can also take a lot of your time and a lot of downtime for that server. 

View original post 447 more words

Get mac address from Mikrotik CAPsMAN Registration Table is no comment. TO Access List

Script :

Get mac address  from CAPsMAN Registration Table is no comment. compare with dhcp server leases mac and add active host name, address list and comment to access list in CAPsMAN.

NOW We know who connect on CAPsMAN.

{
/caps-man registration-table {
:local SSID;:local MAC; :local AP
:foreach rule in=[print detail as-value where (!comment~””)\
# :foreach rule in=[print detail as-value where (comment~”LAO”)\
# interface=”AP_EE”
] do={\
# :put $rule
:set AP “”; :set MAC “”; :set SSID “”
:local num 0
:foreach item in=$rule do={
:if ($num = 2) do={ :set AP $item }
:if ($num = 3) do={ :set MAC $item }
:if ($num = 4) do={ :set SSID $item }
:set num ($num + 1)
}
:local HOSTNAME [ /ip dhcp-server lease get [/ip dhcp-server lease find mac-address=$MAC ] host-name ]
:local ADDRLIST [ /ip dhcp-server lease get [/ip dhcp-server lease find mac-address=$MAC ] address-lists ]
:local COMMENTHOST [ /ip dhcp-server lease get [/ip dhcp-server lease find mac-address=$MAC ] comment ]
:put ($HOSTNAME . $ADDRLIST . “, ” . $COMMENTHOST)

:put ($AP .” ” . $MAC . ” ” . $SSID)
/caps-man access-list {
add mac-address=$MAC action=accept comment=($HOSTNAME . $ADDRLIST . “, ” . $COMMENTHOST) disabled=yes
move [find mac-address=$MAC] destination=1
}
:delay delay-time=10ms
}
}
}

Mikrotik Active User Hotspot In A Day

แก้ไขค่า Comment ให้ตรงค่าของเรา นะครับ

Please edit comment mikrotik user match you comment.

{
# Calculates day of the week for a givien date
# Month: jan,feb … nov,dec (must be lower-case)
# Day: 1 – 31
# Year: 1900 – 2999
# mmm/dd/yyyy same format as [/system clock get date]
# (ex. jul/22/2009)

:local date [/system clock get date]

# Math Calculation here
:local result “”
:local months [:toarray “jan,feb,mar,apr,may,jun,jul,aug,sep,oct,nov,dec”]
:local monthtbl [:toarray “0,3,3,6,1,4,6,2,5,0,3,5”]
:local daytbl [:toarray “sun,mon,tue,wed,thu,fri,sat”]

:local month [:pick $date 0 3]
:local day [:pick $date 4 6]
:local dayc [:pick $date 5 6]
:local century [:pick $date 7 9]
:local year [:pick $date 9 11]
:local yearc [:pick $date 10 11]

# if the first char is a 0 (zero) only read last char, else script fails
:if ([:pick $date 4 5] = 0) do={ :set day ($dayc)}
:if ([:pick $date 9 10] = 0) do=[:set year ($yearc)]

:local sum 0
:set sum ($sum + (2 * (3 – ($century – (($century / 4) * 4)))))
:set sum ($sum + ($year / 4))
:set sum ($sum + $year + $day)
:for mindex from=0 to=[:len $months] do={
:if ([:pick $months $mindex] = $month) do={:set sum ($sum + [:pick $monthtbl $mindex]) }
}
:set sum ($sum – (($sum / 7) * 7))
:set result [:pick $daytbl $sum]

# END Math Calculation

:put ([:pick $date 0 3] . “/” . [:pick $date 4 6] . “/” . [:pick $date 7 9] . [:pick $date 9 11] . ” is on a ” . $result)
#:log info ([:pick $date 0 3] . “/” . [:pick $date 4 6] . “/” . [:pick $date 7 9] . [:pick $date 9 11] . ” is on a ” . $result)

:if ($result = “mon”) do={/ip hotspot user set disable=no [find comment=Monday]} else= {/ip hotspot user set disable=yes [find comment=Monday]}
:if ($result = “tue”) do={/ip hotspot user set disable=no [find comment=Tuesday]} else= {/ip hotspot user set disable=yes [find comment=Tuesday]}
:if ($result = “wed”) do={/ip hotspot user set disable=no [find comment=Wednesday]} else= {/ip hotspot user set disable=yes [find comment=Wednesday]}
:if ($result = “thu”) do={/ip hotspot user set disable=no [find comment=Thursday]} else= {/ip hotspot user set disable=yes [find comment=Thursday]}
:if ($result = “fri”) do={/ip hotspot user set disable=no [find comment=Friday]} else= {/ip hotspot user set disable=yes [find comment=Friday]}
:if ($result = “sat”) do={/ip hotspot user set disable=no [find comment=Saturday]} else= {/ip hotspot user set disable=yes [find comment=Saturday]}
:if ($result = “sun”) do={/ip hotspot user set disable=no [find comment=Sunday]} else= {/ip hotspot user set disable=yes [find comment=Sunday]}
}